Samsung Galaxy S4 Forum

Support Android File Transfer (for Mac) "Could not connect to device"

I have installed Android File Transfer on my Mac but, although it recognises when the phone is connected and autostarts, I get the error message "Could not connect to device. Try connecting or restarting your device."

Connecting doesn't work (it's already connected but disconnecting and reconnecting doesn't either) and nor does restarting.

Has anyone got this to work on their S4?



#1 lotus49, May 11, 2013
I have this working. Had to reboot the Mac too. Then all seemed fine. I was also trying to get Easy Phone Sync to work at the same time and cant remember exactly what the reboot cured, except the mac/S4 wouldn't talk to each other until I rebooted the mac then both bits of software work fine.
#2 apkeene, May 12, 2013
Hey Guys,

Im hunting down a solution from Samsung now :)
#3 Manning, Jun 2, 2013
Hey guys,

I found this tutorial on Samsung's website. It says Its only for 1 particular model but I have a GT-I9505 (International model) and it worked perfectly!

#4 Manning, Jun 2, 2013
#5 Canesfan, Jun 2, 2013
Did you just delete the app or did you use the uninstaller that came with it?

If you did just delete it. Reinstall it then use the uninstaller. Then reboot your computer. That's what I did and it FINALLY worked. Hope that works for you.
#6 SkorpionHalo, Jun 5, 2013
I deleted the app and reinstalled and uninstalled on 2-3 different occasions. I re-booted so many times in conjunction with doing this I have a few pair of boots ;).

Unfortunately, none of this worked for me. Thanks anyway.
#7 Canesfan, Jun 5, 2013
Here's how to properly Uninstall Samsung Kies
#8 SeaBreeze87, Jun 5, 2013
I had this problem and spent quite a bit of time trying to sort it out. I kept uninstalling Kies via the download and restarting. In the end it worked. Don't know whether it was because I did it enough times, or that instead of restarting my mac laptop I did a complete shut down and then turned it on again. The other thing I did was that whilst I was connected to the mac I switched between the connection settings, from media to camera and then back again.... Thanks for all the advice guys.
#9 b0zza1, Jun 16, 2013
I had this problem too and fixed it after reading this thread (thanks Canesfan). Here are the steps which worked for me:

(I am running Mac)

1. To uninstall Kies, I ran the 'dmg' file which I had downloaded last week (KiesMac_2.0.0.13023_10_1.dmg) That is the same file which was used to instal Kies just a week ago.
2. chose to uninstall Kies
3. Rebooted after uninstall
4. I then plugged in my phone (Note 2) and ran Android File Transfer, and it worked! first time.
#10 paul2, Jun 23, 2013
I had the same issue even after uninstalling Kies and restarting the MBP. What did it was on the S4 changing the USB PC Connection from Media (MTP) to Camera (PTP) and back to MTP. AFT immediately recognized the device after that.
#11 mntest, Jun 24, 2013
This did the trick. It worked for me after the reboot. Thank you!
#12 vprabu, Jul 18, 2013
#13 Xenden, Aug 4, 2013
Important! You must uninstall Kies for Mac before running Android File Transfer. Otherwise, the application will not connect to your device. <- This is where most people go wrong

It worked out perfectly on MacBook Pro, it even was not necessary to reboot.
After uninstalling Kies, it showed the files immediately... MANY THANKS!
#14 rolschleich, Sep 23, 2013
Don't forget you can always use the Thanks! button when someone has been helpful.

I did forget but seeing this post re-surface reminded me to Thank Manning's post.
#15 lotus49, Sep 23, 2013
I'm very grateful for this. It all works perfectly as set out - on my new Note 3. Files to and fro of all types. Reminds me of an ancient System 7 or thereabouts application called "Apple File exchange" you used to have to use to deal with loading fonts into the system.

Tested all sorts of data every which way both to/from phone and to/from MicroSD card, created my own directories on the card and everything. The Mac certainly can't read that card in a card reader.

So now how do I back up the entire phone - everything - to a Mac drive?

[​IMG] [​IMG] [​IMG]
#16 Simon_Gardner, Sep 26, 2013
My Android File Transfer was working just fine yesterday, but now it only recognizes files on my "phone" but not on my "card". When I click on the "card" tab a window pops up with a message similar to "if your device is locked, unlock and reconnect USB". My phone is unlocked and I even tried in the "debugging" mode. I have also restarted my device (MacBook Pro) several times. I am using a Galaxy S4. Help! :)
#17 pbizzle, Oct 20, 2013
It's very flaky. Apple needs to deal with this problem.

You rebooted your Mac. Did you reboot the phone? You unplugged the cable and replugged it? The cable/plugs are undamaged? Did you remove and reseat the card?

You removed Kies, completely, right?
#18 Simon_Gardner, Oct 21, 2013
#19 jaysoft7, Jan 22, 2014
Thanks guys. I had the same problem, first time I just clicked on move to trash to delete Kies, but it didn't work. Only after reading this post and following it did I succeed!!
#20 Wholearmour, Jan 27, 2014
I use Android File Transfer maybe daily or more. It's a kludge and works maybe 60% of the time. Quite often the connection falls over for no apparent reason.

Horrible way to do things.
#21 Simon_Gardner, Feb 13, 2014
I never have downloaded Kies. What else could be the problem?
#22 MEDELLINHEEL, Feb 27, 2014
You've already got Kies on your Note 3 out of the box. You need to go through the procedure to deinstall it. Just trashing it is not enough.
#23 Simon_Gardner, Feb 28, 2014
Android File Transfer Not Working with Samsung Device : Error message Can't access device storage : if your device's screen is locked, disconnect it's USB cable, unlock your screen, and then reconnect the USB cable.

My Fix worked on a Galaxy Tab 3

From the home screen go to Settings / More settings / Media share / Nearby devices / File sharing. Make sure the box next to File sharing is checked. Worked for me, hope this helps.:)
#24 Hope311, Apr 27, 2014
I used to face the same problems... I uninstalled Kies using the kies uninstaller and then tried executing the android file transfer software.. and it worked flawlessly...

Kies used to hang frequently while copying files from fone to my mac... but as mentioned in one of the threads here.. I un-installed kies and tried Android file transfer and it worked.

#25 shivoham31, Jun 11, 2014