Samsung Galaxy S7 Forum

Support Gameservice needs update

Two days ago a notification appeared that Gameservice is updated. If I tap it it opens the Galaxy App store and can't connect to network.

I don't play games, did nothing to have caused thus and it reappears after every reboot.

Any ideas what this is about?


#1 camphill, Jun 23, 2016
Game Service is just part of the Game Tools app.
#2 chanchan05, Jun 23, 2016
I too, have no desire to use games on my S7. I also received the update for Gameservice. The thing I don't care for is taht I can not disable either.
#3 jshaw42, Jun 23, 2016
I get a notification that GameService has been updated. . . daily. . . at least once a day. Is there any way to disable this? I don't play games and this notification is annoying. I don't know if it's actually updating or not, but I'd think that it wouldn't update
#4 hoofbeats95, Jun 24, 2016
I'd think it would go away if you disable GameTools. That apps function is to provide power saving features for gaming anyway. If you don't use it, you can disable it.
#5 chanchan05, Jun 25, 2016
I have the same issue I just upgraded from a Galaxy S6 and I have GameTools & Game Launcher off. In fact it has never been on. I took the phone out of the box and did a transfer of content by charging cable two days ago. I don't care about games etc enable or not but updating same file every day is nuts and there hardly any information online about it.
#6 Randalllind, Jun 25, 2016 Last edited: Jun 25, 2016
Can you give me specific instructions to disable? When I long press the notification I can only force stop. It doesn't appear in the app list. It also doesn't seem to be updating as the version number remains the same. I'm tired of the notification!
#7 hoofbeats95, Jun 25, 2016
Me too. How can we kill GameService?
#8 VaughnMc, Jun 25, 2016
I, too, would like to get rid of the persistent GameService update. I do not use my phone for games.
#9 jshaw42, Jun 25, 2016
Same here, have had the S7 Edge for a month or so and EVERY DAY it says that GameService needs to update.

I have Game Tools disabled and that hasn't made a difference.
#10 dcmidnight, Jun 25, 2016
Ok. Glad I'm not the only one. Ridiculously annoying and have to assume it's using data as well
#11 Darren McGruther, Jun 25, 2016
I have had my S7 since ~April, but the daily (sometimes multiple times/day) update of GameService only started ~one week ago. I have now force stopped the app, but others experience suggests this will do nothing. I could also turn off the notifications, which might make the updates less annoying, but that doesn't change the invasive nature of these updates.
I did not have/play any games UNTIL ~one week ago, I installed the 'free' GearVR that finally arrived. I downloaded the free apps (system and yes, games). I tried the Gear long enough to realize it would not work for me because I have very very different vision corrections required for my 2 eyes (no contacts). I have not touched it since ... but I wonder if all the Oculus Gear software installed/enabled that GameService app? I guess I could try disabling or removing all that Oculus stuff (but I'd rather not try).
#12 BobNewbie, Jun 26, 2016
I could not disable either Game Service or Game Tools. I did force stop both. After a restart, the notice, "Gameservice is updated" reappeared. I also got a message that it could not open Galaxy Apps. I will be going to Verizon to find out what can be done.
#13 jshaw42, Jun 26, 2016 Last edited: Jun 26, 2016
Go to application manager. Then to Samsung push services and click on notifications. Enable "Hide on lock screen". Did this 3 days ago and no more notification
#14 display1214, Jun 27, 2016
Thanks, display1214. I've also turned off Previews in pop-ups. I guess this suggests that some software updates from Samsung are pushed to our devices without asking us (this was just a notification, not a request to download if we wanted). The only Samsung app I use is My Files.
#15 BobNewbie, Jun 27, 2016
That is NOT what most people here are asking. ;) They & myself want it disabled. GONE!
When I got to Application Manager/more/show system apps/game service or game tools
both disable & force stop are greyed out. Same thing happens when I go to Notifications/more/show system apps/game service or game tools.

I don't play games and I want this stopped, not running in background!
Maybe the gear VR could be behind this too? I I use that, but not to play games.
#16 jack58, Jun 28, 2016
Try Package Disabler app. It has solved this problem for me with no repetitions/reoccurrences.
#17 Snakeyeskm, Jun 28, 2016
Went to the local Verizon office and no one there knew how to disable this condition. They think it is harmless and does not put any drain on the battery. It is still an annoyance.
#18 jshaw42, Jun 28, 2016
Very annoying when it pops up on your screen when you turn on your phone.
Thing is, it didn't start doing that until last week after the last update... and I've had this phone three months now. So why did it start now???
#19 jack58, Jun 28, 2016
Yes to all of the above. The daily notification is soooo annoying. I've disabled the Galaxy Apps, notifications on any Samsung game stuff, Samsung Push Service, and the all the other suggestions. And I'm still getting this notification. Going to keep following this thread to see if anyone makes progress on this . . .
#20 nmurphy423, Jun 28, 2016
I too have this problem. Tried uninstalling update, and force stop, and still may not disable nor get rid of this notification. I also do not play Samsung Games. I've also pressed on the notice and declined, and still get more notifications of updates for something I have not granted permission too. Once you decline you may not get to the Samsung Play Store to update the app you are not using. Which is supposed to stop these notices but then its still running and doing who knows what to our devices. Samsung are you listening. I wouldn't recommend and S7 unless I hate you. Was great before the last update. Flaming balls of fire are being sent Samsungs way. Hopefully someone on the other side of the world has their ears burning.
#21 ksanger, Jun 28, 2016
I thought I had shut off every notification possible - yet today it was BACK AGAIN!
#22 dcmidnight, Jun 30, 2016
I thought I did too. Spent a week searching for solutions online and here, spent time in "application & notifications" all the way into system apps and no joy. Finally did a Factory reset two days ago and the problem went away... for now. I still would like to know what the heck that is and why it was there and can't be removed???
#23 jack58, Jun 30, 2016
root and delete that sammy trash lol
#24 Curtis1973, Jul 2, 2016
I read somewhere that it could be related to Samsung Push Service. Try disabling that?
#25 chanchan05, Jul 2, 2016