HTC EVO 4G Forum

Support {How to} fix sd card not being seen (for root and non root users)

so it seems that a few of you guys out there are having issues with getting your sd card being seen by your pc. so here is the solution. but first this is not my solution. i take no credit for this.

the original thread can be found here:
[ How-To ] Fix SD card not being detected & USB port not working

this will work for non rooted phones as well as rooted ones.

and here is what you will need to do: these files:
2.create a folder and call it android(you can call it anything you want really) and move the files over to the folder
3.on your phone go to settings>apps>uncheck fastboot
4.connect your phone to the pc via the usb cable
5.power the phone off then press and hold power+vol down.
6.this will take your phone to the bootloader select fastboot(not the same thing in the phone's settings)
7.the bootloader menu should change from fastboot to fastboot usb on your pc, you want to open the command window with path directed to the android folder. if you are on windows 7 you can just right click while holding down the shift button and then select open command window here. the command window enter this command:
Code (Text):
  1. fastboot oem enableqxdm 0
then press enter enter this command:
Code (Text):
  1. fastboot reboot
this should fix your sd card not being recognized.


#1 ocnbrze, Oct 22, 2012
I tried doing this ( dl the 3 files, put them in a "android" folder. Placed folder on desktop for whatever reason) followed all other directions and the command window tells me that 'fastboot is not recognized as an internal or external command'. For some reason the sd card is not being recognized on my laptop...even though, it worked Saturday. I grabbed a file from it and placed it on my laptop, deleted the file from the sd card. And now doesn't work. When I hook it up to the laptop, the prompts pop up and then tells me it failed. (unknown device....code43). USB debugging on/off, fastboot unchecked. The Evo isn't hooked up, I just use it to transfer files. Lemme know what's up, thanks.
#2 ScarHead06, Jul 29, 2013
you might need to reformat your sd card. what size card do you have?
#3 ocnbrze, Jul 30, 2013
8gb I couldn't find where to do that. I wanted to, just couldn't find it. Also don't know why it worked one day, then not the next and telling me it's not recognized.... cuz it saw it Sat. Lol. I mean, it's not really a BIG DEAL, but it's principalities now, lol. Plus I wanna transfer files. Thanks.
#4 ScarHead06, Jul 30, 2013
ok so the above fix,

make sure that you are in the bootloader and that you select fastboot from the menu. also make sure that you are opening up the command window from the folder with the above files in it.
#5 ocnbrze, Jul 30, 2013
So, I want to open that folder (Android) and THEN open the command thing? I was wondering what up meant by "directed" to the folder in the initial post.
#6 ScarHead06, Jul 30, 2013
if you are on windows 7/8 the easiest way is to hold the shift while right clicking on the folder you created with the above files, then select "open command window here" option.

when you open the command window the path should be something like:
Code (Text):
  1. c:\user\ocnbrze\desktop\android>
you want the path to point to the android folder like in the above example.
#7 ocnbrze, Jul 30, 2013
Cool, I'll give er a shot in a bit.
#8 ScarHead06, Jul 30, 2013
If doesn't change to fastboot USB after I choose fastboot, I have to arrow down one time and then it changes. And this phone is real finiky on hooking up. PC dings whenever I move the phone. So, not sure if it's hooked up or not. Either way, the path worked..
C:\Users\(my name)\android>
I type in the command, but is that a capital letter O or number 0? I tried both and it stays on < waiting for device >
#9 ScarHead06, Jul 30, 2013
This is what the bootloader screen looks like
RADIO-2.15. 00.12.19
Dec 21 2011,12:50:32



#10 ScarHead06, Jul 30, 2013