Samsung Galaxy S3 Forum

Support I can't access 'My Files' folder in my phone! Help!

I cannot access 'My Files' folder in my phone. It just won't let me in in any folder. When I go App Drawer > My Files > All Files, it just stays there like I haven't clicked it. I tried going into other folders like Music, Videos, Documents, but it just stays there like I haven't done anything. Can anyone help me?


#1 brndtte, Apr 23, 2013
Hello and welcome to the forum:)

Try going to settings, application manager, all tab, my files and clear data. Don't worry, it won't delete any files you have saved.
#2 Shotgun84, Apr 23, 2013
Whoa. It worked! Thanks so much! I thought I'd have to clean my phone. If only I could hug you from here!!!

And I thought I might have to wait for, like, days before someone could help me here. You're fast :) Thanks again. A bunch.

Anyway, what might have been the problem here? Too much memory consumption? Maybe too much garbage... XD So that I can avoid doing what stupidity I might have done.
#3 brndtte, Apr 23, 2013
No problem, I'm glad you're sorted. Have a good day:)
#4 Shotgun84, Apr 23, 2013
I'm not sure there's really anything you could do to make that happen again so finding the cause would be hard. I think it's just one of those things with technology, however advanced it is sometimes it will just decide to throw a wobbly.
#5 Shotgun84, Apr 23, 2013
I have similar problem on my Samsung GT-I9100 (android 4.1.2). When i try to open My Files folder/ All files or Music or Documents it goes back to desktop (like if i have pushed "back" button). Strange, but at the same time it opens Images and Videos folder with no problem.
I think problem is in storage/sdcard0 - because it also crashes Cool Reader app when im trying to access sdcard0 for books. Play Music and Music player apps dont work too - same as above, minimizing back to desktop/mainpage.
Regretfully above Shotgun84's advice didnt help. Rescan SD app from Play store didnt help too.
Need help.
#6 Androidouser, Apr 24, 2013
Welcome to the forum.

All I can really think of is to try clearing data for media storage and then reboot your phone.
#7 Shotgun84, Apr 24, 2013
Regretfully that didnt help me to solve problem. I also tried to remove most of the files from android to PC and reboot - nothing.
I have installed android terminal emulator to track error that occurs when im trying to open my files/all files folder - but cannot do that, log is too big and im not sure im entering proper commands.
Btw i can access storage/sdcard0 folder from terminal by "cd" command.
I wanna try some other methods before formatting phone (especially because im not sure that backup will restore all files properly).
Any ideas?
#8 Androidouser, Apr 25, 2013
Update. Just installed aLogcat and it caught some errors:

W/ResourceType(12836): Failure getting entry for 0x010802c0 (t=7 e=704) in package 0 (error -75)
E/SpannableStringBuilder(12836): SPAN_EXCLUSIVE_EXCLUSIVE spans cannot have a zero length
What does it mean? Does it help to solve my problem?

ES File Explorer doesnt work too, same as when i try to open all files folder - app is automatically minimizing back to desktop.

Maybe there are other ways to track error above?
#9 Androidouser, Apr 25, 2013
Finally solved this problem. Thanks to this advice: Samsung GT-I9100 Galaxy S II -
Its on russian, user sega++ told me that he had same problem because of file name in Cyrillic more than 50 symbols.
I figured out that problem is same when trying to access sdcard0 and sdcard0/Music. So i input command "ls" in sdcard0/Music folder (android terminal user) - there was one file "Shot - ...and then 5-6 empty lines...". Then i connected phone to PC and find this mp3 file in Music folder - "Shot - ...more than 100 Cyrillic symbols...". What da hell, who downloaded this? Hrrr, never give phone to friends!
Renamed, deleted, problem solved!
Thanks android forums, thanks sega++, thanks Internet!
#10 Androidouser, Apr 26, 2013
Argh, should've looked here weeks ago. Thank you Shotgun! Saved me too!
#11 SamsungGallaxy, Jul 7, 2013
No problem and welcome to the forum:)
#12 Shotgun84, Jul 8, 2013
Hello I am trying to fix my phone i have a galaxy s 2 skyrocket and it has the same problem as you did androidoser can you help me to fix my phone please ?
#13 kikoto, Jan 5, 2014
I had this problem and it was driving me insane. (Caused by an unintentionally downloaded .mp3 file with a stupid and long name.)

I was going to resort to just backing up all my files except for the file with a very long name and format my android phone but luckily found a fix which was more convenient.

How I fixed it: Plugged my phone into my PC via USB cable.
On my phone, went into settings, more settings, USB utilities, and click connect storage to PC.
Opened 7zip and went to the problematic file with the very long name, renamed it to a short name (e.g. BAD FILE) and deleted it.

This fixed it for me. I hope that helps people. :)
#14 AndroidSavior1, Jun 24, 2014
Guys i cleared data myfiles and nothing happens... any other way?
sorry for my bad english im just gettin insane

i checked in my pc when i connect it i cant delete the file that i dont even know what is it "μORMAL~1" and μOOTHE~1
#15 Claux, Oct 19, 2014
Howdy...just found this thread since I am having a similar phone (Droid) does not recognize my ringtones... it uses my 'notification' sounds as ringtones....tried to clear the data as suggested above, but I do not have a 'application manager' in my settings.... any ideas where it might be? or how do I clear the data?? thanks!
#16 littlefilly, Dec 5, 2014
I don't know Motorolas but it could be named just "applications"
#17 funkylogik, Dec 5, 2014