Alcatel OneTouch Fierce 2 Forum


Has Anyone Found A Root For this Device ?



#1 xFreakz, Feb 27, 2015
Hey Man, as of now there is no root for this phone, me and some others are working on this over here:
Maybe you can contribute with us =)
#2 GTizzle, Feb 28, 2015
I have rooted my 7040n
#3 LigitSkillz, May 31, 2015
Worked for me had to try a few times but its worth it. Now we need recovery.
#4 Keysersoze66, May 31, 2015
I root my with kinguser
#5 RicanFlow37, Jun 1, 2015
Kinguser people
#6 RicanFlow37, Jun 1, 2015
I used the same post #42 and gained root. Its tricy @ first but you will see what the challenge is and be able to root
#7 GREATONE, Jun 11, 2015
I used Kingroot and got it to work also. Here was my process. First time I tried it, it rebooted and did not work. I restarted the Kingroot apk and hit the root button again. Second time was the charm. It said root granted and indeed it is. Hope this helps.
#8 nicklessdagrif, Jun 17, 2015
Would you kindly tell us how you accomplished this?

Many thanks.
#9 Wordhewer, Sep 22, 2015
This has been my problem for so long now, month's looking for a boot but never found one. Lemme know if anyone dose.
#10 Keymaster1210, Oct 1, 2015
I rooted mine using Kingroot and anatutu bench mark. It took me 4 tries but gained root access. Videos of this process can be found on You Tube. Now I'm running into a problem updated the binary and gaining super user control. Has anyone found a way to update the binary? Screenshot_2015-10-08-12-08-03.png
#11 GregDF, Oct 8, 2015
Just wanted to say thank you for all your help. I'm able to root my alcatel using anatutu and kingroot (ver. 4.5 English). It's a bit odd but although kingroot told me the rooting "failed," when I went to kingroot, it says my device has been rooted. I'm able to use xmodgames and uninstall pre-installed programs. Did the anatutu twice and then ran kingroot (anatutu at 14% and then 18% respectively).
#12 Slinking, Oct 26, 2015
Just got mine to root with no problem finally. Go to and download the windows pc version, make sure your phone is in Media device (MTP) mode and have debugging enabled before you start the rooting process. Enjoy!!
#13 DonPFunkRuSta, Jan 22, 2016 Last edited: Feb 28, 2016
I am no genius and I rooted my Alcatel Fierce 2 model no n7040N, and without any headache. After doing a root checker and it failing I downloaded AnTu Tu Benchmark and then used KINGROOT 4.1 APK. Worked on my first try. Now what do I do next? Now if I can figure out how to use my SD card as default storage so my phone isn't slow all the time and will actually let me put some apps on the damn thing!
#14 heather stewart, Feb 28, 2016
my alcatel phone 7040n stay on home screen only disply alcatel softwear crupted solution plz
#15 gurmeet2355, May 9, 2016