LG Ally Forum

Root PDAnet sharing

I have a LG Ally and I use Pdanet by a USB wire. I thought: It would be cool to share the connection. (Not for gaming or anything big, just for something to have around) So my dad suggested I use The network and sharing center, open up the pdanet settings, set it to share, then plug in a switch from my internet port in the back of the switch, then people can hook up to the switch and share. So I tried sharing and I kept getting a error
"Cannot enable shared access" Error 0x80004005: Unspecified error. I looked it up and tried using services for the firewall and sharing internet things. But I got no luck. I'm using Windows 7 Professional x64 Bit. I couldnt fix the error and I'm stuck. Can someone answer my question? (sorry if it is confusing It's hard to explain for me.) A answer would be appreciated. -Mason


#1 Mason27Johnson, Nov 5, 2011
I'm fairly certain this won't work correctly because it's a usb wired connection.

However, are familiar with rooting your phone? If so, you could root, and then turn your phone into a wireless access point where multiple things can connect at once (although more then about 2 is not recommended due to stress on the phone)
#2 imnotmikal, Nov 5, 2011
No I dont wanna do a wireless sharing like a hotspot, I mean go into the settings and tell it to share, then hook up to the a switch so people can hook up into the switch and hook up to the pdanet access. I keep getting that error, I dont get why everytime I try fixing it by looking up how it doesnt work every time. I just wanna share it using a switch and by hooking up the switch to my computer. and why would wired not work? isnt wired the whole point of sharing it?
#3 Mason27Johnson, Nov 5, 2011
that may be a windows issue. Check your adapter settings. If you have ip address and the adapter is connected to a network, try clearing the address. disable and re-enable the connection and try again. I used to be able to share pdanet connection and any other connection with windows 7, although it has given me strange ******ed errors, you just have to fiddle with the settings. Also try unplugging the lan cord and enable ICS and then plug the cord back in. Also, make sure you're not interfering with another service on the network. If you have a router that has ip routing then you may have to disable the router and use it as a hub or switch. It can be a real nightmare and can cause you to have to reconfigure your entire network. I remember this has caused me grief and I had to shut down my linksys router, plug in a switch, and then reconfigure windows as the ip router because it really doesnt like changes very much and it will configure the network as it tries to become the host and do ip routing itself.
#4 WhyMyAlly, Nov 6, 2011
I fixed the issue, turns out the problem was my local area connection was disabled, thats why the sharing thing didnt wanna turn on. Thanks for the help anyways. :):)
#5 Mason27Johnson, Nov 12, 2011