Samsung Galaxy Tab 10.1 Forum

Support Samsung Galaxy Tab 10.1 Wifi Connection Issues

HI there, I have a Samsung Galaxy Tab 10.1 WiFi version which is having connectivity issues, I have read online that there are many with the same problem but havent been able to find a solution.

When you connect to the WiFi the connection works but for some reason after a few days it stops working.

The tab shows that you are connected and I get full bars but you just can't connect.

I have tried Samsung online support and they dont want to know about it because I am in Australia, they ask me to call Australian support.

I call Samsung Australia and they don't know how to fix the problem.

Note that I have done a hard reset in the past and it has fixed the problem but it just comes back after a few days.

Any help is appreciated..


#1 malhyp, Mar 30, 2012
Try rebooting your modem.
Mine and my wife TABs play up with WiFi and do kind of reboot, and i noticed that it was
only happening at home while on our WiFi and not anywhere else, once we reboot the modem they come all good.
Worth a go!!

#2 Pep, Apr 1, 2012
I have exactly the same issue, and only with my home WiFi. All connections away from home work first time.
Having to reboot the rooter and/or the Tab is, honestly, a pain in the @rse!
Let's hope this is fixed when the ICS upgrade comes out.
#3 CargoMatatu, Apr 3, 2012
#4 Thorsten, Apr 3, 2012

as mentioned in the post - Factory Reset
#5 Kyrotech, Apr 3, 2012
Yes, and then he goes on to say it just comes back after a couple of days! :-(
#6 CargoMatatu, Apr 4, 2012
My problem is usually anywhere BUT home! WHat is a problem for me is - finding an option for entering username and password info that is often required by wifi networks!
he tab shows it's connected (NOT!), but won't go anywhere - and I KNOW it's because I need to enter that info - - but it usually does not give me an option to do so!! EVEN whn I tell it to "Forget" that wifi connection
#7 lweaverk, May 3, 2012
If it's only with that one connection, the problem probably isn't the Tab, and probably won't be fixed with any upgrade to the Tab.
#8 meyerweb, May 14, 2012
I've had zero problems with WiFi. It is probably your router or modem that is the problem.
#9 GirlFriday, May 14, 2012
#10 bfksc, May 18, 2012
Belkin and D-Link routers are garbage. I recommend Netgear or ASUS. Linksys isn't bad either all though they've gone downhill.
#11 GirlFriday, May 18, 2012
Hi All;
I have a high end Linksys Router and have the same issue. In my case, if I power cycle the Tab's WiFi, it always reconnects. I am a fan of Android and for the most part this is a solid product but Samsung gets low marks for support. I would have bought a IPAD 2 except that I need Flash. If there are SAMSUNG folks watching these post, please do not ignore these messages.
#12 VinceEP, May 28, 2012
You have to narrow it down and isolate the issue one by one. First things first is, make sure that you have this problem on all wifi connection. If it is only at your home, it's probably and issue with your wireless router or your ISP.

I also have this issue but I find the router as the culprit. Every time I go to e wifi freezone, even if I have only 1 bar, the connection is stable but when I am at home, it turns on and off, I replaced my router and that's it.
#13 latebloomer, May 30, 2012
I have a Cradlepoint router with a Verizon broadband card. Been using the same combo for years. In all that time I've never had the router be the cause of losing connectivity. I can see in the router software when Verizon stops working, & it's always the data card. I reconnect with the data card & off I go. Not complaining about Verizon because sometimes days go by that I don't have to reset, but if I have a problem, it's never the router.

Also, to the person who doesn't get the dialog to enter a password - if you are connecting to a router that does MAC filtering but doesn't have a password, I don't think you will get an error message or option to enter a password. When I first got my Wifi Tab I forgot to add the MAC to the router, and that's exactly what happened. Added the MAC & I've been good to go ever since.
#14 ComputerGranny, Jun 4, 2012
My wife and I both have the 10.1 WIFI only tabs.
My router is a Linksys wired model that I bought in 2007.
I installed an Apple Airport Express for wireless access for the tablets (the only
wireless devices we have).
Our tablets always connect without issues (haven't tried connecting via WIFI in locations
other than our home).
As others have posted, your router is the likely issue.
#15 Jacksmyname, Jun 6, 2012
Well, we have a Cisco WAP 2000 and no need to say that is NOT a shitty wap. There is never an issue to connect our laptops to the wap.

Got a tab2 Wifi & mobile. In the initial setup, 'network disabled, poor connection'. After the initial setup via the settings, same thing. AFter a factory rest, same thing.

It finds the Wifi, connects, gets an IP adress, and then gives always the same message...

Very strange because all the other devices connect without problems, also my HTC sense, my wife's Xperia, my HP laptop, her Samsung laptop,... So I find it hard to believe that is would be the wap who causes the problem!

Any ideas here?
#16 Cisse, Sep 2, 2012
Hello Android Fans,
I have a Samsung Galaxy Tab 10.1.
I can't get it to recognize my Modem. It doesn't even pick up my neighbors signal.
I have a Cisco Modem/Router from Xfinity.
I don't know how to get the Tab Recognize any WiFi signals. It basically scans and nothing.
Please Help.
#17 Will Royale, Sep 28, 2012
Let's start with the basics. I don't want to sound condescending or anything, but we should cover the basics before resorting to more drastic measures. If you don't know the answer to one or more of these questions, ask and maybe we can help. Also, what version of Android are you running; most people run 4.0.4 these days, but 3.2 is still rather popular and seems to be more prone to these issues.

Is the WiFi is turned on?
Is the tablet out of airplane mode?
Can you see a message appear every 10 seconds or so that it is actively scanning?
Are any public WiFi signals appearing, for instance if you take it to a Starbucks or other public WiFi hot spot?
Has it ever worked in the past?
If so, have you made any changes since it last worked?
Have you tried taking it back to the store you bought it from and asking them to try and connect it?
Have you tried a factory reset?
#18 Coach70, Sep 29, 2012
I have wifi issues with all my Samsung devices at home. I have a Netgear CG3100 in my bedroom, where I mainly use my devices. Full wifi signal from this router and it will drop off a lot.

I have a Netgear WGT634U in my garage also broadcasting a WLAN. I get 2 bars (half as much) coverage from my bedroom - works perfectly.

Both routers are Netgear. Previous to the CG3100 I had a Billion BiPAC 4707 VGO I think it is. Would act the same as the CG3100.

The WGT634U has an Atheros WLAN chip in it. From a quick look, I think the CG3100 has Broadcom. I am not 100% sure, but I think it comes down to which WiFi chipset is in your router. Some chis just don't play well together.

Any other wireless devices I have (Toshiba L650 laptop) has no issue with the CG3100 wifi.

I always go back to what I've always said. If you can possibly plug a cable in that's the best option. Wifi still bites the big wang in my opinion.

The convenience and versatility of new tablet and phone devices make it worth putting up with dodgfy wifi though. You just have to search out hardware that will work with your brands.
#19 Catfish, Oct 5, 2012
My issues, are only with my 7510-wifi tablet, and only since the ICS upgrade. Never had a problem before.
This house is running Macs, Iphones, Ipads, Pc's, Gingerbread, ICS galaxy 3 with no issues but ICS on the tablet upgrade is not happy!

I get connected, I surf, I walk away, and I have to turn the Wi-fi off and back on to get a connection. So it doesn't keep it's connection after it goes to sleep. Not like before the ICS upgrade.

Still searching.
#20 tdjclarke, Oct 8, 2012
i have the same issues although mine survives short sleep, but it does lose connection overnight. :thinking:
#21 DAE51D, Oct 19, 2012
Log in to home page of Router
Collect data required, password, email addresses etc
Wireless password.

RESTORE router back to factory settings, not just reboot

enter back passwords, email addresses

connect back tablet to router through wireless and will work.

This has to be done through a pc ethernet connection

if using fibre optic broadband, you do not need passwords to log on.

Could not work out why my Samsung phoneand tablet connected at home but not at training centre, done this and both work now perfect. ;)
#22 dazzaboy, Jan 2, 2013
I had the same problem, showed full connection status but says no connection when trying to open something up.
Did it at home and out at wifi hotspots
Not being hugely technical I went for the easy option first-I deleted all the apps I had downloaded and also the updates to the installed apps. This has fixed the problem and I am just putting apps and updates back on one at a time to see if it happens again.
Hope this helps.
#23 guzziman100, Jan 13, 2013
have an ace and netgear router.
the ace actually connects fine when i turn the computer wifi connection off. i just can't connect the galaxy ace when the computer is online. i just wanted to add one suggestion nobody here seems to have addressed. just because the galaxy works everywhere but home, it still doesn't mean it's your router. some internet access providers don't let you connect with more than one device at a time. if you are already connected and try to connect with another device, they will block it. when you signed up for internet access, did you check off the box saying you were going to be connecting with more than one device? if you connect everywhere but home, try turning your computer off or just clicking on your computer wifi connection and turning off the wifi, then try connecting with your phone. in my case the phone connects 100% no problem when i shut off the computer wifi connection
#24 cristo_, Mar 7, 2013
So I have a Samsung tab 2 10.1 which keeps losing wifi. It was fine for about 4/5 months but now won't stay connected. My husband has exactly the same model (bought together) and his is fine. Its got to the point where I cant even load a web page without losing connection. I have tried all the below to no avail...

- Resetting the router whilst 'forgetting' the connection on the tab and reconnecting again.
- Resetting the whole tab. I tried to connect several times as a blank canvass, with just factory settings no apps etc, still kept losing connection.
- Switching off husbands tab to see if its the router getting stroppy about having two tabs online.

Don't know what else to try...
It can't be the router, all other devices (2 x laptops, 2 x mobiles, Wii, Playstation, husbands tab 2, ipod touch) all work fine at the same time with no connectivity issues.

Is there anything else to try or have I just got a broken tab?
#25 BobbySparkles, Jul 8, 2013